swayfx/debian/rules
2024-06-15 15:14:44 -06:00

30 lines
589 B
Makefile
Executable file

#!/usr/bin/make -f
# -*- makefile -*-
export DH_VERBOSE=1
export DH_OPTIONS=-v
include /usr/share/dpkg/pkg-info.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_CFLAGS_MAINT_APPEND = -Wno-error=deprecated-declarations
export DEB_BUILD_OPTIONS=noautodbgsym
%:
dh $@
.PHONY: override_dh_auto_configure
override_dh_auto_configure:
dh_auto_configure -- --libexecdir=lib
.PHONY: override_dh_missing
override_dh_missing:
dh_missing --fail-missing
.PHONY: override_dh_install
override_dh_install:
if ! dh_install; then \
tree debian; \
exit 1; \
fi